Degraded Performance on Libraries

Incident Report for LibreTexts Systems

Resolved

The issue with the third-party service provider has been resolved. Libraries are operating normally.
Posted Jun 26, 2026 - 21:38 UTC

Identified

An issue with a third-party service provider has been identified and a fix is being implemented.
Posted Jun 26, 2026 - 17:11 UTC

Investigating

Our libraries are currently experiencing degraded performance and unexpected behavior. We are working to restore normal function as soon as possible. We apologize for any inconvenience.
Posted Jun 26, 2026 - 16:31 UTC
This incident affected: Libraries (Chemistry, Biology, Business, Engineering, Espanol, Geology, Humanities, K-12 Education, Mathematics, Medicine, Physics, Social Sciences, Statistics, Workforce, Ukrayinska, Global).